CVE-2026-2611
In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.
- CVSS 3.1
- 9.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-346, CWE-940
- Published
- Modified
- Record from
- the NVD, synced
Affected
- lfprojects:mlflow
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-67c5-x5mf-rppq | PyPI | mlflow | >=3.9.0 <3.10.0 | 3.10.0 |
| PYSEC-2026-418 | PyPI | mlflow | >=3.9.0 <3.10.0 | 3.10.0 |
References
- https://github.com/mlflow/mlflow/commit/8f9c8a53af90842944101eb8b7d60706822c81bc
- https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a
- https://access.redhat.com/security/cve/CVE-2026-2611
- https://bugzilla.redhat.com/show_bug.cgi?id=2479797
- https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a