CVE-2026-25700
Improper Restriction of Security Token Assignment vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
- CVSS 3.1
- 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-25)
- CWE
- CWE-1259
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:answer
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-4gw2-vg4x-7p29 | Go | github.com/apache/incubator-answer | <2.0.1 | 2.0.1 |
| GHSA-4gw2-vg4x-7p29 | Go | github.com/apache/answer | <2.0.1 | 2.0.1 |
| GO-2026-6249 | Go | github.com/apache/answer | all versions | no fix published |
| GO-2026-6249 | Go | github.com/apache/incubator-answer | all versions | no fix published |