CVE-2026-24880
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - EPSS
- 0.7% chance of exploitation in the next 30 days; higher than 52% of CVEs (scores of 2026-10-26)
- CWE
- CWE-444
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-563x-q5rq-57qp | Maven | org.apache.tomcat:tomcat-coyote | >=7.0.0 <9.0.116 | 9.0.116 |
| GHSA-563x-q5rq-57qp | Maven | org.apache.tomcat:tomcat-coyote | >=10.1.0-M1 <10.1.52 | 10.1.52 |
| GHSA-563x-q5rq-57qp | Maven | org.apache.tomcat:tomcat-coyote | >=11.0.0-M1 <11.0.20 | 11.0.20 |
| GHSA-563x-q5rq-57qp | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=7.0.0 <9.0.116 | 9.0.116 |
| GHSA-563x-q5rq-57qp | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=10.1.0-M1 <10.1.52 | 10.1.52 |
| GHSA-563x-q5rq-57qp | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=11.0.0-M1 <11.0.20 | 11.0.20 |