cve.bz

CVE-2026-23864

7.5 highEPSS 2.6%

High (7.5) in facebook react. EPSS 2.6% chance of exploitation in the next 30 days. Fixed in react-server-dom-parcel 19.0.4, 19.1.5, 19.2.4.

Multiple denial of service vulnerabilities exist in React Server Components, affecting the following packages: react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack. The vulnerabilities are triggered by sending specially crafted HTTP requests to Server Function endpoints, and could lead to server crashes, out-of-memory exceptions or excessive CPU usage; depending on the vulnerable code path being exercised, the application configuration and application code. Strongly consider upgrading to the latest package versions to reduce risk and prevent availability issues in applications using React Server Components.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.6% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
CWEs
CWE-400, CWE-502, CWE-1284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-parcel>=19.0.0 <19.0.419.0.4
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-turbopack>=19.1.0-canary-7130d0c6-20241212 <19.1.519.1.5
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-webpack>=19.2.0-canary-63779030-20250328 <19.2.419.2.4
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-turbopack>=19.0.0 <19.0.419.0.4
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-parcel>=19.1.0-canary-7130d0c6-20241212 <19.1.519.1.5
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-parcel>=19.2.0-canary-63779030-20250328 <19.2.419.2.4
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-webpack>=19.1.0-canary-7130d0c6-20241212 <19.1.519.1.5
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-webpack>=19.0.0 <19.0.419.0.4
GHSA-83fc-fqcc-2hmgnpmreact-server-dom-turbopack>=19.2.0-canary-63779030-20250328 <19.2.419.2.4

References

Check your stackJSON