cve.bz

CVE-2026-22031

8.8 highEPSS 0.5%

High (8.8) in fastify fastify\/middie. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in @fastify/middie 9.1.0.

@fastify/middie is the plugin that adds middleware support on steroids to Fastify. A security vulnerability exists in @fastify/middie prior to version 9.1.0 where middleware registered with a specific path prefix can be bypassed using URL-encoded characters (e.g., `/%61dmin` instead of `/admin`). While the middleware engine fails to match the encoded path and skips execution, the underlying Fastify router correctly decodes the path and matches the route handler, allowing attackers to access protected endpoints without the middleware constraints. Version 9.1.0 fixes the issue.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-11-01)
CWE
CWE-177
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cxrg-g7r8-w69pnpm@fastify/middie<9.1.09.1.0

References

Check your stackJSON