CVE-2026-115946
No CVSS score yet. EPSS 0.2% estimated probability of exploitation activity in the next 30 days.
XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder.
Affected versions compile a bundled brotli into static archives that dependent XS modules link against at build time, rather than using the system library. The bundled copy, 1.0.7 or 1.1.0 across the range, carries the decoder out-of-bounds write described in CVE-2026-111497. Version 1.2.1.0 updates it to brotli 1.2.1.
XS::libbrotli has no Perl interface, so the decoder is reached through any dependent module that decompresses untrusted data with it. An attacker supplying a crafted brotli stream can corrupt decoder state, disclose memory, crash the process, or potentially execute arbitrary code. Upgrading the system brotli does not remediate this.
- EPSS
- 0.2% estimated probability of exploitation activity in the next 30 days; 16th percentile. Scored 2026-11-01. A forecast for this CVE across the internet, not for your own systems.
- Published
- Modified
- Record from
- the NVD, synced
Ask an AI about this CVE
ChatGPTClaudePerplexityGoogle AI Mode
Show the prompt
Explain CVE-2026-115946 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-115946?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-115946?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an estimate of exploitation activity across the internet over the next 30 days, not a prediction for my systems). Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.