cve.bz

CVE-2026-11572

7.4 highEPSS 1.0%

High (7.4). EPSS 1.0% chance of exploitation in the next 30 days. Fixed in degit 2.8.6, 3.3.1.

Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.

Severity

CVSS 4.0

7.4 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
1.0% chance of exploitation in the next 30 days; higher than 64% of CVEs (scores of 2026-11-01)
CWEs
CWE-78, CWE-77
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-77c7-pq4r-6mcqnpmdegit<2.8.62.8.6
GHSA-77c7-pq4r-6mcqnpmdegit>=3.0.0 <3.3.13.3.1

References

Check your stackJSON