cve.bz

CVE-2026-11500

1.3 lowEPSS 0.3%

Low (1.3). EPSS 0.3% chance of exploitation in the next 30 days. Fixed in github.com/weaviate/weaviate 1.38.0-rc.0.

A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.

Severity

CVSS 4.0

1.3 low
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

CVSS 3.1

5.0 medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
0.3% chance of exploitation in the next 30 days; higher than 27% of CVEs (scores of 2026-10-31)
CWEs
CWE-285, CWE-639
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-jqpm-wf57-qx5cGogithub.com/weaviate/weaviate<1.38.0-rc.01.38.0-rc.0
GO-2026-6140Gogithub.com/weaviate/weaviate<1.38.0-rc.01.38.0-rc.0

References

Check your stackJSON