CVE-2026-111822
No CVSS score yet.
Improper invalidation of cached authorizations vulnerability in Apache ActiveMQ, Apache ActiveMQ Runtime Config.
After the runtime configuration plugin removes a principal's write grant on a destination, an authenticated connection opened before the change can keep sending to that destination, including through a new anonymous producer, while fresh connections and new explicit producers are denied.
This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ Runtime Config: from 6.0.0 before 6.3.3, before 5.19.12.
Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
- Published
- Modified
- Record from
- the NVD, synced
Ask an AI about this CVE
Show the prompt
Explain CVE-2026-111822 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-111822?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-111822?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an internet-wide 30-day estimate of exploitation activity, not a forecast for my systems). If they give no fixed versions, use the CVE record https://cveawg.mitre.org/api/cve/CVE-2026-111822 or the vendor advisory, not third-party mirrors. Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.
Versions
From the CNA's record in the CVE List.
| Product | Affected |
|---|---|
| Apache Software Foundation Apache ActiveMQ | from 6.0.0 before 6.3.3 |
| Apache Software Foundation Apache ActiveMQ | before 5.19.12 |
| Apache Software Foundation Apache ActiveMQ Runtime Config | from 6.0.0 before 6.3.3 |
| Apache Software Foundation Apache ActiveMQ Runtime Config | before 5.19.12 |