CVE-2026-111821
No CVSS score yet.
Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB.
A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable.
This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12.
Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
- CWE
- CWE-20 Improper Input Validation
- Published
- Record from
- the NVD, synced
Ask an AI about this CVE
Show the prompt
Explain CVE-2026-111821 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-111821?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-111821?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an internet-wide 30-day estimate of exploitation activity, not a forecast for my systems). If they give no fixed versions, use the CVE record https://cveawg.mitre.org/api/cve/CVE-2026-111821 or the vendor advisory, not third-party mirrors. Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.
Versions
From the CNA's record in the CVE List.
| Product | Affected |
|---|---|
| Apache Software Foundation Apache ActiveMQ | from 6.0.0 before 6.3.3 |
| Apache Software Foundation Apache ActiveMQ | before 5.19.12 |
| Apache Software Foundation Apache ActiveMQ KahaDB | from 6.0.0 before 6.3.3 |
| Apache Software Foundation Apache ActiveMQ KahaDB | before 5.19.12 |
Attack patterns (CAPEC)
The attack patterns MITRE's CAPEC relates to this record's weaknesses, as MITRE names them. Credits. More on the page of CWE-20 (51).