CVSS 4.0
5.1 mediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NMedium (5.1). EPSS 1.0% estimated probability of exploitation activity in the next 30 days. Fixed in @angular/platform-server 20.3.33, 21.2.25, 22.2.1.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExplain CVE-2026-111754 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-111754?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-111754?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an internet-wide 30-day estimate of exploitation activity, not a forecast for my systems). If they give no fixed versions, use the CVE record https://cveawg.mitre.org/api/cve/CVE-2026-111754 or the vendor advisory, not third-party mirrors. Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.
From the CNA's record in the CVE List.
| Product | Affected |
|---|---|
| angular | <= 19.2.25 |
| angular | >= 20.0.0, < 20.3.33 |
| angular | >= 21.0.0, < 21.2.25 |
| angular | >= 22.0.0, < 22.2.1 |
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-w739-gvwx-grc3 | npm | @angular/platform-server | >=22.0.0 <22.2.1 | 22.2.1 |
| GHSA-w739-gvwx-grc3 | npm | @angular/platform-server | >=21.0.0 <21.2.25 | 21.2.25 |
| GHSA-w739-gvwx-grc3 | npm | @angular/platform-server | >=20.0.0 <20.3.33 | 20.3.33 |
| GHSA-w739-gvwx-grc3 | npm | @angular/platform-server | <=19.2.25 | no fix published |
The attack patterns MITRE's CAPEC relates to this record's weaknesses, as MITRE names them. Credits.