CVE-2026-106100
Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.
- CVSS 3.1
- 7.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N - EPSS
- 0.2% chance of exploitation in the next 30 days; higher than 11% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-639, CWE-915
- Published
- Modified
- Record from
- the NVD, synced
Affected
- payloadcms:payload
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-4ww4-68q3-h7g5 | npm | @payloadcms/db-mongodb | <3.87.0 | 3.87.0 |
| GHSA-4ww4-68q3-h7g5 | npm | @payloadcms/db-mongodb | >=4.0.0-canary.0 <4.0.0-canary.20 | 4.0.0-canary.20 |
References
- https://github.com/payloadcms/payload/commit/2a69863deb0e3c87e36c1b3b17ab2d5b02fcb941
- https://github.com/payloadcms/payload/commit/8f77dffa9552885ec2710768cfee15b57e389935
- https://github.com/payloadcms/payload/releases/tag/v3.87.0
- https://github.com/payloadcms/payload/security/advisories/GHSA-4ww4-68q3-h7g5