CVE-2026-105163
A vulnerability was detected in crossplane crossplane-runtime up to 2.2.2/2.3.2. This vulnerability affects the function Get of the file pkg/xpkg/client.go of the component ImageConfig. The manipulation results in time-of-check time-of-use. The attack may be launched remotely. Upgrading to version 2.2.3, 2.3.3 and 2.4.0-rc.1 is able to resolve this issue. The patch is identified as bee99c6cd6ca81878acca2940a2f0a02169fc208. You should upgrade the affected component.
- CVSS 4.0
- 6.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 24% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-362, CWE-367
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-mf7q-r4rv-jv94 | Go | github.com/crossplane/crossplane-runtime/v2 | >=2.4.0-rc.0 <2.4.0-rc.1 | 2.4.0-rc.1 |
| GHSA-mf7q-r4rv-jv94 | Go | github.com/crossplane/crossplane-runtime/v2 | >=2.3.0 <2.3.3 | 2.3.3 |
| GO-2026-6302 | Go | github.com/crossplane/crossplane-runtime/v2 | >=2.3.0 <2.3.3 >=2.4.0-rc.0 <2.4.0-rc.1 | 2.3.3, 2.4.0-rc.1 |
References
- https://github.com/advisories/GHSA-mf7q-r4rv-jv94
- https://github.com/crossplane/crossplane-runtime/
- https://github.com/crossplane/crossplane-runtime/commit/bee99c6cd6ca81878acca2940a2f0a02169fc208
- https://github.com/crossplane/crossplane-runtime/pull/1038
- https://github.com/crossplane/crossplane-runtime/releases/tag/v2.2.3