cve.bz

CVE-2026-103932

5.8 medium

Medium (5.8) in owasp-modsecurity modsecurity.

On this page
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.5 until 3.0.17, the PCRE2 implementation of @rxGlobal in src/utils/regex.cc converts pcre2_match match-limit errors into an ordinary no-match result instead of propagating a non-OK RegexResult. When attacker-controlled input exhausts SecPcreMatchLimit, rules that rely on MSC_PCRE_LIMITS_EXCEEDED or its TX compatibility indicator do not run, so a request that should be rejected can pass through the WAF. The issue affects PCRE2 deployments that use @rxGlobal with a limit-exhaustible expression and a compensating rule; it is not a universal WAF bypass. This issue is fixed in version 3.0.17.

Severity

CVSS 3.1

5.8 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
CWE
CWE-253 Incorrect Check of Function Return Value
Published
Record from
the CVE List, synced

Ask an AI about this CVE

Show the promptExplain CVE-2026-103932 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-103932?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-103932?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an internet-wide 30-day estimate of exploitation activity, not a forecast for my systems). If they give no fixed versions, use the CVE record https://cveawg.mitre.org/api/cve/CVE-2026-103932 or the vendor advisory, not third-party mirrors. Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.

Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.

Affected

Versions

From the CNA's record in the CVE List.

ProductAffected
owasp-modsecurity ModSecurity>= 3.0.5, < 3.0.17

Linux distributions

DistributionReleasePackageFixed inAdvisory
Debian12, 13, 14modsecurityno fix listedDEBIAN-CVE-2026-103932
Ubuntu20.04:LTS, 22.04:LTS, 24.04:LTS and 2 moremodsecurityno fix listedUBUNTU-CVE-2026-103932

From the distributions' data via OSV.dev: the Debian Security Tracker; Ubuntu Security Notices © Canonical Ltd., CC BY-SA 4.0. Modified: reformatted and linked to CVE records. Credits. On the distributions' own pages: Debian · Ubuntu.

References

Check your stackJSON