cve.bz

CVE-2026-102278

7.5 highEPSS 0.5%

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.

CVSS 3.1
7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 39% of CVEs (scores of 2026-10-25)
CWEs
CWE-400, CWE-674
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qhr7-859c-m2p7npmbrace-expansion>=4.0.0 <5.0.115.0.11
GHSA-qhr7-859c-m2p7npmbrace-expansion>=3.0.0 <3.0.83.0.8
GHSA-qhr7-859c-m2p7npmbrace-expansion>=2.0.0 <2.1.62.1.6
GHSA-qhr7-859c-m2p7npmbrace-expansion<1.1.201.1.20

References

Check your stackJSON