cve.bz

CVE-2025-68145

6.4 mediumEPSS 7.0%

In mcp-server-git versions prior to 2025.12.17, when the server is started with the --repository flag to restrict operations to a specific repository path, it did not validate that repo_path arguments in subsequent tool calls were actually within that configured path. This could allow tool calls to operate on other repositories accessible to the server process. The fix adds path validation that resolves both the configured repository and the requested path (following symlinks) and verifies the requested path is within the allowed repository before executing any git operations. Users are advised to upgrade to 2025.12.17 upon release to remediate this issue.

CVSS 4.0
6.4CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
CVSS 3.1
9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
7.0% chance of exploitation in the next 30 days; higher than 94% of CVEs (scores of 2026-10-25)
CWE
CWE-22
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-j22h-9j4x-23w5PyPImcp-server-git<2025.12.182025.12.18
PYSEC-2026-1623PyPImcp-server-git<2025.12.182025.12.18

References

Check your stackJSON