cve.bz

CVE-2025-66516

9.8 criticalEPSS 89%

Critical (9.8) in apache tika. EPSS 89% chance of exploitation in the next 30 days. Fixed in org.apache.tika:tika-core 3.2.2.

Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
89% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWE
CWE-611
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f58c-gq56-vjjfMavenorg.apache.tika:tika-core>=1.13 <3.2.23.2.2
GHSA-f58c-gq56-vjjfMavenorg.apache.tika:tika-parsers>=1.13 <2.0.02.0.0
GHSA-f58c-gq56-vjjfMavenorg.apache.tika:tika-parser-pdf-module>=2.0.0 <3.2.23.2.2

References

Check your stackJSON