CVE-2025-66412
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 21.0.2, 20.3.15, and 19.2.17, A Stored Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. It occurs because the compiler's internal security schema is incomplete, allowing attackers to bypass Angular's built-in security sanitization. Specifically, the schema fails to classify certain URL-holding attributes (e.g., those that could contain javascript: URLs) as requiring strict URL security, enabling the injection of malicious scripts. This vulnerability is fixed in 21.0.2, 20.3.15, and 19.2.17.
- CVSS 4.0
- 8.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 35% of CVEs (scores of 2026-10-25)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- angular:angular
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-v4hv-rgfq-gp49 | npm | @angular/compiler | >=21.0.0-next.0 <21.0.2 | 21.0.2 |
| GHSA-v4hv-rgfq-gp49 | npm | @angular/compiler | >=20.0.0-next.0 <20.3.15 | 20.3.15 |
| GHSA-v4hv-rgfq-gp49 | npm | @angular/compiler | >=19.0.0-next.0 <19.2.17 | 19.2.17 |
| GHSA-v4hv-rgfq-gp49 | npm | @angular/compiler | <=18.2.14 | no fix published |