CVE-2025-66040
Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.
- CVSS 3.1
- 3.6
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N - EPSS
- 0.2% chance of exploitation in the next 30 days; higher than 4% of CVEs (scores of 2026-10-25)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-r77h-rpp9-w2xm | PyPI | spotipy | <2.25.2 | 2.25.2 |
| PYSEC-2026-1937 | PyPI | spotipy | <2.25.2 | 2.25.2 |