CVE-2025-65105
Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
- CVSS 3.1
- 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - EPSS
- 0.2% chance of exploitation in the next 30 days; higher than 13% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-61, CWE-706
- Published
- Modified
- Record from
- the NVD, synced
Affected
- lfprojects:apptainer
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-j3rw-fx6g-q46j | Go | github.com/apptainer/apptainer | <1.4.5 | 1.4.5 |
| GO-2025-4176 | Go | github.com/apptainer/apptainer | <1.4.5 | 1.4.5 |
References
- https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981
- https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2
- https://github.com/apptainer/apptainer/pull/3226
- https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j
- https://github.com/opencontainers/runc/security/advisories/GHSA-cgrx-mc8f-2prm