CVE-2025-64775
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- 1.5% chance of exploitation in the next 30 days; higher than 74% of CVEs (scores of 2026-10-25)
- CWE
- CWE-459
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:struts
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-xx7v-hqxh-cjr9 | Maven | org.apache.struts:struts2-core | >=6.0.0 <6.8.0 | 6.8.0 |
| GHSA-xx7v-hqxh-cjr9 | Maven | org.apache.struts:struts2-core | >=7.0.0 <7.1.1 | 7.1.1 |
| GHSA-xx7v-hqxh-cjr9 | Maven | org.apache.struts:struts2-core | >=2.0.0 <=2.3.37 | no fix published |
| GHSA-xx7v-hqxh-cjr9 | Maven | org.apache.struts:struts2-core | >=2.5.0 <=2.5.33 | no fix published |