CVE-2025-64751
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.
- CVSS 4.0
- 5.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H - CVSS 3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 24% of CVEs (scores of 2026-10-25)
- CWE
- CWE-285
- Published
- Modified
- Record from
- the NVD, synced
Affected
- openfga:helm_charts
- openfga:openfga
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-2c64-vmv2-hgfc | Go | github.com/openfga/openfga | >=1.4.0 <1.11.1 | 1.11.1 |
| GO-2025-4150 | Go | github.com/openfga/openfga | >=1.4.0 <1.11.1 | 1.11.1 |