CVE-2025-64408
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- CVSS 3.1
- 6.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - EPSS
- 12% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-25)
- CWE
- CWE-502
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:causeway
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-wq4c-57mh-5f7g | Maven | org.apache.causeway.commons:causeway-commons | <3.5.0 | 3.5.0 |
| GHSA-wq4c-57mh-5f7g | Maven | org.apache.causeway.core:causeway-applib | <3.5.0 | 3.5.0 |
| GHSA-wq4c-57mh-5f7g | Maven | org.apache.causeway.core:causeway-core | <3.5.0 | 3.5.0 |
| GHSA-wq4c-57mh-5f7g | Maven | org.apache.causeway.viewer:causeway-viewer-wicket | <3.5.0 | 3.5.0 |