cve.bz

CVE-2025-62372

8.3 highEPSS 0.4%

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

CVSS 4.0
8.3CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
CVSS 3.1
6.5CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 34% of CVEs (scores of 2026-10-25)
CWE
CWE-129
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pmqf-x6x8-p7qwPyPIvllm>=0.5.5 <0.11.10.11.1
PYSEC-2026-2019PyPIvllm>=0.5.5 <0.11.10.11.1

References

Check your stackJSON