CVE-2025-62233
Deserialization of Untrusted Data vulnerability in Apache DolphinScheduler RPC module. This issue affects Apache DolphinScheduler: Version >= 3.2.0 and < 3.3.1. Attackers who can access the Master or Worker nodes can compromise the system by creating a StandardRpcRequest, injecting a malicious class type into it, and sending RPC requests to the DolphinScheduler Master/Worker nodes. Users are recommended to upgrade to version [3.3.1], which fixes the issue.
- CVSS 3.1
- 6.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-25)
- CWE
- CWE-502
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:dolphinscheduler
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-f786-9c63-8xr8 | Maven | org.apache.dolphinscheduler:dolphinscheduler | >=3.2.0 <3.3.1 | 3.3.1 |
| GHSA-f786-9c63-8xr8 | Maven | org.apache.dolphinscheduler:dolphinscheduler-rpc | >=3.2.0 <3.3.1 | 3.3.1 |