CVE-2025-6210
A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for hardlink-based path traversal. This flaw permits attackers to bypass path restrictions and access sensitive system files, such as /etc/passwd, by exploiting hardlinks. The vulnerability arises from inadequate handling of hardlinks in the load_data() method, where the security checks fail to differentiate between real files and hardlinks. This issue is resolved in version 0.5.2.
- CVSS 3.0
- 6.2
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 26% of CVEs (scores of 2026-10-25)
- CWE
- CWE-22
- Published
- Modified
- Record from
- the NVD, synced
Affected
- llamaindex:llamaindex
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-3j8r-jf9w-5cmh | PyPI | llama-index-readers-obsidian | <0.5.2 | 0.5.2 |
| PYSEC-2025-252 | PyPI | llama-index | <0.5.2 | 0.5.2 |
| PYSEC-2026-1567 | PyPI | llama-index-readers-obsidian | <0.5.2 | 0.5.2 |