CVE-2025-61734
Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 26% chance of exploitation in the next 30 days; higher than 97% of CVEs (scores of 2026-10-25)
- CWE
- CWE-552
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:kylin
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin-common-server | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin-common-service | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin-core-common | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin-core-metadata | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin-ops-server | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-p86w-w5rh-m3hx | Maven | org.apache.kylin:kylin-server | >=4.0.0 <5.0.3 | 5.0.3 |