CVE-2025-61622
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
- CVSS 3.1
- 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS
- 45% chance of exploitation in the next 30 days; higher than 98% of CVEs (scores of 2026-10-25)
- CWE
- CWE-502
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:fory
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-538v-3wq9-4h3r | PyPI | pyfory | >=0.12.0 <0.12.3 | 0.12.3 |
| GHSA-538v-3wq9-4h3r | PyPI | pyfury | >=0.1.0 <=0.10.3 | no fix published |
| PYSEC-2026-490 | PyPI | pyfory | >=0.12.0 <0.12.3 | 0.12.3 |
| PYSEC-2026-491 | PyPI | pyfury | >=0.1.0 <=0.10.3 | no fix published |