cve.bz

CVE-2025-60012

6.3 mediumEPSS 0.5%

Medium (6.3) in apache livy. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in org.apache.livy:livy-server 0.9.0-incubating.

Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

Severity

CVSS 3.1

6.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
0.5% chance of exploitation in the next 30 days; higher than 42% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hm8x-rpgg-7855Mavenorg.apache.livy:livy-server>=0.7.0-incubating <0.9.0-incubating0.9.0-incubating

References

Check your stackJSON