cve.bz

CVE-2025-59048

8.1 highEPSS 0.3%

OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin. A workaround for this issue involves guaranteeing that IAM role names are unique across all AWS accounts that could potentially interact with your OpenBao environment, and to audit for any duplicate IAM roles.

CVSS 3.1
8.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 18% of CVEs (scores of 2026-10-25)
CWEs
CWE-694, CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-jp7h-4f3c-9rc7Gogithub.com/openbao/openbao-plugins<0.1.10.1.1
GO-2025-4067Gogithub.com/openbao/openbao-pluginsall versionsno fix published

References

Check your stackJSON