cve.bz

CVE-2025-59037

8.6 highEPSS 0.4%

High (8.6). EPSS 0.4% chance of exploitation in the next 30 days. Fixed in duckdb 1.3.4.

DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/node-api@1.3.3`, `@duckdb/node-bindings@1.3.3`, `duckdb@1.3.3`, and `@duckdb/duckdb-wasm@1.29.2` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.

Severity

CVSS 4.0

8.6 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 31% of CVEs (scores of 2026-10-31)
CWE
CWE-506
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w62p-hx95-gf2cnpmduckdb>=1.3.3 <1.3.41.3.4
GHSA-w62p-hx95-gf2cnpm@duckdb/node-api>=1.3.3 <1.3.4-alpha.271.3.4-alpha.27
GHSA-w62p-hx95-gf2cnpm@duckdb/node-bindings>=1.3.3 <1.3.4-alpha.271.3.4-alpha.27
GHSA-w62p-hx95-gf2cnpm@duckdb/duckdb-wasm>=1.29.2 <1.30.01.30.0

References

Check your stackJSON