cve.bz

CVE-2025-5889

1.3 lowEPSS 0.6%

Low (1.3). EPSS 0.6% chance of exploitation in the next 30 days. Fixed in brace-expansion 1.1.12, 2.0.2, 3.0.1.

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

Severity

CVSS 4.0

1.3 low
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

CVSS 3.1

3.1 low
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
0.6% chance of exploitation in the next 30 days; higher than 48% of CVEs (scores of 2026-10-31)
CWEs
CWE-400, CWE-1333
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v6h2-p8h4-qcjwnpmbrace-expansion>=2.0.0 <2.0.22.0.2
GHSA-v6h2-p8h4-qcjwnpmbrace-expansion>=1.0.0 <1.1.121.1.12
GHSA-v6h2-p8h4-qcjwnpmbrace-expansion>=3.0.0 <3.0.13.0.1
GHSA-v6h2-p8h4-qcjwnpmbrace-expansion>=4.0.0 <4.0.14.0.1

References

Check your stackJSON