CVE-2025-58360
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
- CVSS 3.1
- 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS
- 60% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-25)
- CISA KEV
- listed 2025-12-11, due 2026-01-01
- CWE
- CWE-611
- Published
- Modified
- Record from
- the NVD, synced
Affected
- geoserver:geoserver
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-fjf5-xgmq-5525 | Maven | org.geoserver.web:gs-web-app | >=2.26.0 <2.26.2 | 2.26.2 |
| GHSA-fjf5-xgmq-5525 | Maven | org.geoserver:gs-wms | >=2.26.0 <2.26.2 | 2.26.2 |
| GHSA-fjf5-xgmq-5525 | Maven | org.geoserver.web:gs-web-app | <2.25.6 | 2.25.6 |
| GHSA-fjf5-xgmq-5525 | Maven | org.geoserver:gs-wms | <2.25.6 | 2.25.6 |