CVE-2025-58352
Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.
- CVSS 4.0
- 2.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 21% of CVEs (scores of 2026-10-25)
- CWE
- CWE-613
- Published
- Modified
- Record from
- the NVD, synced
Affected
- weblate:weblate
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-377j-wj38-4728 | PyPI | weblate | <5.13.1 | 5.13.1 |
| PYSEC-2026-2036 | PyPI | weblate | <5.13.1 | 5.13.1 |