CVE-2025-58157
gnark is a zero-knowledge proof system framework. In version 0.12.0, there is a potential denial of service vulnerability when computing scalar multiplication is using the fake-GLV algorithm. This is because the algorithm didn't converge quickly enough for some of the inputs. This issue has been patched in version 0.13.0.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 43% of CVEs (scores of 2026-10-25)
- CWE
- CWE-400
- Published
- Modified
- Record from
- the NVD, synced
Affected
- consensys:gnark
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9fvj-xqr2-xwg8 | Go | github.com/consensys/gnark | >=0.12.0 <0.13.0 | 0.13.0 |
| GO-2025-3929 | Go | github.com/consensys/gnark | <0.13.0 | 0.13.0 |