cve.bz

CVE-2025-58064

2.3 lowEPSS 0.4%

Low (2.3). EPSS 0.4% chance of exploitation in the next 30 days. Fixed in ckeditor5 45.2.2, 46.0.3.

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

Severity

CVSS 4.0

2.3 low
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 36% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-x9gp-vjh6-3wv6npmckeditor5>=46.0.0 <46.0.346.0.3
GHSA-x9gp-vjh6-3wv6npm@ckeditor/ckeditor5-clipboard>=44.2.0 <45.2.245.2.2
GHSA-x9gp-vjh6-3wv6npmckeditor5>=44.2.0 <45.2.245.2.2
GHSA-x9gp-vjh6-3wv6npm@ckeditor/ckeditor5-clipboard>=46.0.0 <46.0.346.0.3

References

Check your stackJSON