CVE-2025-57738
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
- CVSS 3.1
- 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - EPSS
- 23% chance of exploitation in the next 30 days; higher than 97% of CVEs (scores of 2026-10-25)
- CWE
- CWE-653
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:syncope
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-825g-mm5v-ggq4 | Maven | org.apache.syncope.core:syncope-core-spring | <3.0.14 | 3.0.14 |
| GHSA-825g-mm5v-ggq4 | Maven | org.apache.syncope.core:syncope-core-spring | >=4.0.0-M0 <4.0.2 | 4.0.2 |