cve.bz

CVE-2025-54997

9.1 criticalEPSS 0.4%

Critical (9.1) in openbao openbao. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in github.com/openbao/openbao 0.0.0-20250806194004-a14053c9679d, 2.3.2.

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 37% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xp75-r577-cvhpGogithub.com/openbao/openbao>=0.1.0 <2.3.22.3.2
GHSA-xp75-r577-cvhpGogithub.com/openbao/openbao<0.0.0-20250806194004-a14053c9679d0.0.0-20250806194004-a14053c9679d
GO-2025-3858Gogithub.com/openbao/openbao<0.0.0-20250806194004-a14053c9679d
>=0.1.0
0.0.0-20250806194004-a14053c9679d

References

Check your stackJSON