cve.bz

CVE-2025-5472

6.5 mediumEPSS 0.4%

Medium (6.5) in llamaindex llamaindex. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in llama-index-core 0.12.38.

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Severity

CVSS 3.0

6.5 medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-31)
CWE
CWE-674
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3wxx-q3gv-pvvvPyPIllama-index-core<0.12.380.12.38
PYSEC-2025-251PyPIllama-index>=0.12.28 <0.12.380.12.38
PYSEC-2026-1559PyPIllama-index-core<0.12.380.12.38

References

Check your stackJSON