cve.bz

CVE-2025-5175

4.8 mediumEPSS 0.2%

Medium (4.8) in erdogant pypickle. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in pypickle 2.0.0.

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Severity

CVSS 4.0

4.8 medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
0.2% chance of exploitation in the next 30 days; higher than 16% of CVEs (scores of 2026-10-31)
CWEs
CWE-266, CWE-285
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qpxx-2cwh-r5vhPyPIpypickle<2.0.02.0.0
PYSEC-2025-46PyPIpypickle<2.0.02.0.0

References

Check your stackJSON