cve.bz

CVE-2025-5174

4.8 mediumEPSS 0.3%

Medium (4.8) in erdogant pypickle. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in pypickle 2.0.0.

A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Severity

CVSS 4.0

4.8 medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 27% of CVEs (scores of 2026-10-31)
CWEs
CWE-502, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5qwj-342r-h886PyPIpypickle<2.0.02.0.0
PYSEC-2025-45PyPIpypickle<2.0.02.0.0

References

Check your stackJSON