cve.bz

CVE-2025-49585

8.6 highEPSS 0.4%

High (8.6) in xwiki xwiki. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.xwiki.platform:xwiki-platform-security-requiredrights-default 15.10.16, 16.10.2, 16.4.7.

XWiki is a generic wiki platform. In versions before 15.10.16, 16.0.0-rc-1 through 16.4.6, and 16.5.0-rc-1 through 16.10.1, when an attacker without script or programming right creates an XClass definition in XWiki (requires edit right), and that same document is later edited by a user with script, admin, or programming right, malicious code could be executed with the rights of the editing user without prior warning. In particular, this concerns custom display code, the script of computed properties and queries in database list properties. Note that warnings before editing documents with dangerous properties have only been introduced in XWiki 15.9, before that version, this was a known issue and the advice was simply to be careful. This has been patched in XWiki 16.10.2, 16.4.7 and 15.10.16 by adding an analysis for the respective XClass properties.

Severity

CVSS 4.0

8.6 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N

CVSS 3.1

8.0 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-31)
CWE
CWE-357
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-59w6-r9hm-439hMavenorg.xwiki.platform:xwiki-platform-security-requiredrights-default<15.10.1615.10.16
GHSA-59w6-r9hm-439hMavenorg.xwiki.platform:xwiki-platform-security-requiredrights-default>=16.0.0-rc-1 <16.4.716.4.7
GHSA-59w6-r9hm-439hMavenorg.xwiki.platform:xwiki-platform-security-requiredrights-default>=16.5.0-rc-1 <16.10.216.10.2

References

Check your stackJSON