cve.bz

CVE-2025-48989

7.5 highEPSS 3.7%

High (7.5) in apache tomcat. EPSS 3.7% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-coyote 10.1.44, 11.0.10, 9.0.108.

Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
3.7% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWE
CWE-404
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-gqp3-2cvr-x8m3Mavenorg.apache.tomcat:tomcat-coyote>=11.0.0-M1 <11.0.1011.0.10
GHSA-gqp3-2cvr-x8m3Mavenorg.apache.tomcat:tomcat-coyote>=10.1.0-M1 <10.1.4410.1.44
GHSA-gqp3-2cvr-x8m3Mavenorg.apache.tomcat:tomcat-coyote>=9.0.0.M1 <9.0.1089.0.108
GHSA-gqp3-2cvr-x8m3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.0-M1 <11.0.1011.0.10
GHSA-gqp3-2cvr-x8m3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.0-M1 <10.1.4410.1.44
GHSA-gqp3-2cvr-x8m3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.0.M1 <9.0.1089.0.108

References

Check your stackJSON