cve.bz

CVE-2025-47943

6.3 mediumEPSS 0.4%

Medium (6.3). EPSS 0.4% chance of exploitation in the next 30 days. Fixed in github.com/gogs/gogs 0.13.3-0.20250608224432-110117b2e5e5.

Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.

Severity

CVSS 3.1

6.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 33% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xh32-cx6c-cp4vGogithub.com/gogs/gogs<0.13.3-0.20250608224432-110117b2e5e50.13.3-0.20250608224432-110117b2e5e5
GHSA-xh32-cx6c-cp4vGogogs.io/gogs<0.13.3-0.20250608224432-110117b2e5e50.13.3-0.20250608224432-110117b2e5e5
GO-2025-3778Gogogs.io/gogs<0.13.3-0.20250608224432-110117b2e5e50.13.3-0.20250608224432-110117b2e5e5

References

Check your stackJSON