cve.bz

CVE-2025-47291

4.6 mediumEPSS 0.3%

Medium (4.6) in linuxfoundation containerd. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in github.com/containerd/containerd/v2 2.0.5.

containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.

Severity

CVSS 4.0

4.6 medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 21% of CVEs (scores of 2026-10-31)
CWE
CWE-266
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cxfp-7pvr-95ffGogithub.com/containerd/containerd/v2>=2.0.1 <2.0.52.0.5
GO-2025-3701Gogithub.com/containerd/containerd/v2>=2.0.1 <2.0.52.0.5

References

Check your stackJSON