cve.bz

CVE-2025-46701

7.3 highEPSS 3.1%

High (7.3) in apache tomcat. EPSS 3.1% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-catalina 10.1.41, 11.0.7, 9.0.105.

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Severity

CVSS 3.1

7.3 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
3.1% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-178
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat:tomcat-catalina>=9.0.0.M1 <9.0.1059.0.105
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat:tomcat-catalina>=10.1.0-M1 <10.1.4110.1.41
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat:tomcat-catalina>=11.0.0-M1 <11.0.711.0.7
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.0.M1 <9.0.1059.0.105
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.0-M1 <10.1.4110.1.41
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.0-M1 <11.0.711.0.7
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat:tomcat-catalina>=8.5.0 <=8.5.100no fix published
GHSA-h2fw-rfh5-95r3Mavenorg.apache.tomcat.embed:tomcat-embed-core>=8.5.0 <=8.5.100no fix published

References

Check your stackJSON