cve.bz

CVE-2025-4658

9.3 criticalEPSS 0.3%

Critical (9.3) in openpubkey. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in github.com/openpubkey/opkssh 0.5.0.

Versions of OpenPubkey library prior to 0.10.0 contained a vulnerability that would allow a specially crafted JWS to bypass signature verification. As OPKSSH depends on the OpenPubkey library for authentication, this vulnerability in OpenPubkey also applies to OPKSSH versions prior to 0.5.0 and would allow an attacker to bypass OPKSSH authentication.

Severity

CVSS 4.0

9.3 critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 27% of CVEs (scores of 2026-10-31)
CWEs
CWE-347, CWE-305
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-56wx-66px-9j66Gogithub.com/openpubkey/opkssh<0.5.00.5.0
GO-2025-3680Gogithub.com/openpubkey/opkssh<0.5.00.5.0

References

Check your stackJSON