cve.bz

CVE-2025-41242

5.9 mediumEPSS 2.1%

Medium (5.9). EPSS 2.1% chance of exploitation in the next 30 days. Fixed in org.springframework:spring-webmvc 6.2.10.

Spring Framework MVC applications can be vulnerable to a “Path Traversal Vulnerability” when deployed on a non-compliant Servlet container. An application can be vulnerable when all the following are true: * the application is deployed as a WAR or with an embedded Servlet container * the Servlet container does not reject suspicious sequences https://jakarta.ee/specifications/servlet/6.1/jakarta-servlet-spec-6.1.html#uri-path-canonicalization * the application serves static resources https://docs.spring.io/spring-framework/reference/web/webmvc/mvc-config/static-resources.html#page-title  with Spring resource handling We have verified that applications deployed on Apache Tomcat or Eclipse Jetty are not vulnerable, as long as default security features are not disabled in the configuration. Because we cannot check exploits against all Servlet containers and configuration variants, we strongly recommend upgrading your application.

Severity

CVSS 3.1

5.9 medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
2.1% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
CWE
CWE-22
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r936-gwx5-v52fMavenorg.springframework:spring-webmvc>=6.2.0 <6.2.106.2.10
GHSA-r936-gwx5-v52fMavenorg.springframework:spring-webmvc>=6.1.0 <=6.1.21no fix published
GHSA-r936-gwx5-v52fMavenorg.springframework:spring-webmvc>=6.0.0 <=6.0.29no fix published
GHSA-r936-gwx5-v52fMavenorg.springframework:spring-webmvc>=5.3.0 <=5.3.43no fix published

References

Check your stackJSON