cve.bz

CVE-2025-3108

7.5 highEPSS 0.5%

High (7.5) in llamaindex llamaindex. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in llama-index-core 0.12.41.

A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote code execution due to an insecure fallback to Python's pickle module. JsonPickleSerializer prioritizes deserialization using pickle.loads(), which can execute arbitrary code when processing untrusted data. Attackers can exploit this by crafting malicious payloads to achieve full system compromise. The root cause includes an insecure fallback mechanism, lack of validation or safeguards, misleading design, and violation of Python security guidelines.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 42% of CVEs (scores of 2026-10-31)
CWE
CWE-1112
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m84c-4c34-28gfPyPIllama-index-core>=0.11.15 <0.12.410.12.41
PYSEC-2025-249PyPIllama-index>=0.12.27 <0.12.410.12.41
PYSEC-2026-1564PyPIllama-index-core>=0.11.15 <0.12.410.12.41

References

Check your stackJSON