cve.bz

CVE-2025-30218

1.7 lowEPSS 0.4%

Low (1.7) in vercel next.js. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in next 12.3.6, 13.5.10, 14.2.26.

Next.js is a React framework for building full-stack web applications. To mitigate CVE-2025-29927, Next.js validated the x-middleware-subrequest-id which persisted across multiple incoming requests. However, this subrequest ID is sent to all requests, even if the destination is not the same host as the Next.js application. Initiating a fetch request to a third-party within Middleware will send the x-middleware-subrequest-id to that third party. This vulnerability is fixed in 12.3.6, 13.5.10, 14.2.26, and 15.2.4.

Severity

CVSS 4.0

1.7 low
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

CVSS 3.1

5.9 medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 37% of CVEs (scores of 2026-10-31)
CWE
CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-223j-4rm8-mrmfnpmnext>=12.3.5 <12.3.612.3.6
GHSA-223j-4rm8-mrmfnpmnext>=13.5.9 <13.5.1013.5.10
GHSA-223j-4rm8-mrmfnpmnext>=14.2.25 <14.2.2614.2.26
GHSA-223j-4rm8-mrmfnpmnext>=15.2.3 <15.2.415.2.4

References

Check your stackJSON